Linux 上基于swoole做php 微服务架构

双色调zz · · 14 次点击 · · 开始浏览    

Linux 上基于swoole做php 微服务架构

php编译报错configure: error: C++ preprocessor “/lib/cpp” fails sanity check 以及解决办法,错误信息如下:

checking how to run the C++ preprocessor... /lib/cpp
configure: error: in `/usr/local/src/php-7.0.10':
configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details

解决办法:

yum install glibc-headers
yum install gcc-c++

make 报错

clipboard.png

此错误就是要安装openssl

yum install openssl
yum install openssl-devel

本文来自:Segmentfault

感谢作者:双色调zz

查看原文:Linux 上基于swoole做php 微服务架构

14 次点击  
加入收藏 微博
暂无回复
添加一条新回复 (您需要 登录 后才能回复 没有账号 ?)
  • 请尽量让自己的回复能够对别人有帮助
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`
  • 支持 @ 本站用户;支持表情(输入 : 提示),见 Emoji cheat sheet