Centos之php安装指定版本-yellowcong

天佑我儿 · · 277 次点击 · · 开始浏览    
这是一个创建于 的文章,其中的信息可能已经有所发展或是发生改变。

php在centos中,可以通过yum -y install php 来快速安装php,但是这有个缺点,不知道安装的是那一个版本,所以我们需要手动下载安装包,来安装php

php版本问题

php的版本过低的问题

This version of ownCloud requires at least PHP 5.6.0
You are currently running 5.4.16. Please update your PHP version.

这里写图片描述

安装php

下载安装

#下载php的5.6版本
wget http://yellowcong.qiniudn.com/php-5.6.32.tar.gz 

#解压
tar -zxvf php-5.6.32.tar.gz  

#安装php编译依赖,不然会报错
yum install -y libxml2 libxml2-devel 

#配置php
./configure --prefix=/usr/local/php

#编译并安装
make && make install 

#建立管道连接
ln -s /usr/local/php/bin/php ./php

#查看php版本
php -v

配置成功
这里写图片描述

安装完成
这里写图片描述

php版本查看
这里写图片描述

php编译报错

这个问题是由于没有安装依赖的包所导致的
configure: error: xml2-config not found. Please check your libxml2 installation.
这里写图片描述

yum install libxml2

yum install libxml2-devel -y

本文来自:开源中国博客

感谢作者:天佑我儿

查看原文:Centos之php安装指定版本-yellowcong

277 次点击  
加入收藏 微博
暂无回复
添加一条新回复 (您需要 登录 后才能回复 没有账号 ?)
  • 请尽量让自己的回复能够对别人有帮助
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`
  • 支持 @ 本站用户;支持表情(输入 : 提示),见 Emoji cheat sheet